fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: GA 1.0.1 Setup error

GA 1.0.1 Setup error 1 year 8 months ago #1

Congrats on first GA release!

I got this error when installing the 1.0.1 release.

Unable to execute file \HlpCtntMgr.exe
CreateProcess failed; code 2
The system cannot find the file specified.

I checked my system and I can find HlpCtntMgr.exe in C:\Program Files (x86)\Microsoft Help Viewer\v2.2


Running on Windows 10 Pro - Version 1703

Jamal
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by Jamal.

GA 1.0.1 Setup error 1 year 8 months ago #2

Jamal,
strange. No problem here under 8.1/64. Was this your first x# install on that machine?

HTH
Karl

Please Log in or Create an account to join the conversation.

GA 1.0.1 Setup error 1 year 8 months ago #3

Jamal,

The installer looks for a registry key to locate the presence of the Ms Help Manager, the tool that manages the Visual Studio Help collections.
For VS 2015 that key is HKLM\SOFTWARE\Microsoft\Help\v2.2, the string value AppDir.
For VS 2017 that key is HKLM\SOFTWARE\Microsoft\Help\v2.3, the string value AppDir.
Both keys are 32 bit so on a Win64 machine in the WOW6432Node of the Software tree.
This key gets written bij the VS Installer.
I must admit that the installer does not check if the tool is actually there where it is supposed to be.
The default installation of VS write the following locations in the registry:
VS 2015: C:\Program Files (x86)\Microsoft Help Viewer\v2.2\
VS 2017: C:\Program Files (x86)\Microsoft Help Viewer\v2.3\
Both locations should have a file HlpCtntMgr.Exe.

The error during installation may have the result that the X# help collections are not installed in Visual Studio. However the .CHM help file should always be installed in the XSharp\Help folder.

If you want to install the X# Help inside Visual Studio manually, then this is the way to do it:

Inside Visual Studio there is a menu item in the Help menu named "Add and Remove Help Content". If that menu option works on your machine then you should be able to add the X# help to the VS help collection by choosing the "installation source" "Disk" and by pointing to the file "c:\Program Files (x86)\XSharp\Help\XSharp.msha"

Robert
XSharp Development Team
The Netherlands
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

GA 1.0.1 Setup error 1 year 8 months ago #4

Karl,

This is my first install.

Jamal

Karl Faller wrote: Jamal,
strange. No problem here under 8.1/64. Was this your first x# install on that machine?

HTH
Karl

Please Log in or Create an account to join the conversation.

GA 1.0.1 Setup error 1 year 8 months ago #5

Robert,

I only have VS 2017 pro installed, so I modified the installation and added the Help Viewer component.

The install finished, however, I got a "Security Alert", see attached. I know I can trust you guys, but thought to let you know.

See attached image of alert.



Jamal
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by Jamal.

GA 1.0.1 Setup error 1 year 8 months ago #6

Jamal,

That is the "normal" Microsoft confusing behavior. Even when you have allowed the signed installer to run at administrator level and "infect" your machine with all kinds of malware, they still want to annoy you with dialogs like this.

Robert
XSharp Development Team
The Netherlands
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

GA 1.0.1 Setup error 1 year 8 months ago #7

Thanks Roberts,

Just repaired my VS 2015 and 2017 Help.

Rene
--

Rene Pajaron

Please Log in or Create an account to join the conversation.

  • Page:
  • 1