fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Installer - VS 2017 - issues and work arounds !?

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2602

  Phil Hepburn's Avatar Topic Author Phil Hepburn Offline Posts: 742
Hi guys,

well its my turn to have a moan, but I will try to make it a positive moan ;-0)

A couple of months back I happened to find out for myself that there were some possible issues with the publically released Microsoft Visual Studio 2017 Installer. It only seemed to give issues on my office PC when I installed and then removed more than one of the three versions of VS on offer in the Installer. I got into a 'deadly embrace' - after removing all VS versions the Installer would not re-install any version of VS 2017 at all. So I had nothing! I even tried deleting / uninstalling the 2017 Installer itself. Still no joy ;-0((

So I left things for a good while hoping that MS would improve and update its apparently 'broken' Installer.

Well, when I tried the other day, after Robert and the Team released 1.02, the latest Installer was no better, and I still had issues.

So I needed a new approach, 'plan 'B''. I went to a copy of a VM I had created way back, before going to Cologne in April 2017 - this virtual machine (still on my office PC) only had VS 2015 installed, and so it allowed me a chance to do a clean and new install of VS 2017, with the possibly/probably still imperfect Installer. This time I was NOT going to mess around, just do a Professional install of VS2017.

All went well, even downloading the application software file from the internet with a slowish Wi-Fi connection in my VM. After a completed install I then installed the new 1.02 X# compiler and all seems well for my office PC - as long as I use the VM and the Visual Studio within it. So far I have only created a new WPF project - very simple.

I do not think that the Windows Insider 16257 and previous two versions, had anything to do with my problems and issues. It feels as though the Installer does not cleanly remove the bunch of files and folders that it ought, when we do anything but a simple and straight forward install. It then seems to do a check of some sorts when it re-tries to make a new install - it certainly gets its knickers in a twist!

I hope this may help some guys out there. I will try and get my message of 'moaning' through to Microsoft.



Best regards,
Phil.
Wales, UK.
Attachments:

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2607

  ic2's Avatar ic2 Offline Posts: 520
As written earlier, I had installation problems with VS 2017 as well. It looks to me that Microsoft has never realized that people have older Visual Studio versions (e.g. for us here to use Vulcan) and that these are causing the problems. Look at this page:

developercommunity.visualstudio.com/cont...ike-a-serious-s.html

There are many more of these, all with lots of followers (on my message 130). Read the It is solved part. I got excellent help from a Microsoft support engineer in Bangelore. She had to solve it with a lot of trial & error as well. I used one of my 10 Action Pack incidents to solve it. Well, that's a positive Microsoft remark, isn't it Phil?

I finally decided to deinstall VS 2017. I have not seen the promised improvement in speed (It was actually slower for most part) and I am uncertain of it working. I did a clean W10 install on my laptop and on that I only installed VS 2017. As soon as my last Vulcan project is X#, and everything works on that laptop, I probably deinstall VS 2015 on my main system and install VS 2017 again.

Dick

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2608

  NickFriend's Avatar NickFriend Offline Posts: 205
Hi Dick,

I don't think it's the simple fact of having older VS installs that causes problems. I have VS 2008, 2010, 2012, 2013, 2015 and now 2017 on my main development machine. All work without issue.

I think there must be some other factor involved.

Looking at this has reminded me I need to get rid of those older installations!

Nick

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2609

  Phil Hepburn's Avatar Topic Author Phil Hepburn Offline Posts: 742
Hi Nick,

Do be careful when un-installing VS versions!

In the past I did some experimental work on this and published my findings in this forum or the Vulcan one.

If it ain't broke then don't fix it, is my advice. Could be more trouble than its worth.

I do agree with you however, on the mixed VS versions. In the virtual machine I talk of yesterday, I have VS 2017 Pro and VS 2015 (3 update?) installed and running in the VM.

In fact I just did a test to have both running at once and in each 'shell' to have a simple WPF app up and running - at the same time. And there were no issues.

My recollections of the trouble first starting in my general main office Win 10 system, was when It tried to use the 2017 Installer to Remove / Modify an existing VS 2017 version. Up until then I had been running quite successfully the Enterprise version of VS 2017 - alongside VS 2015 to give me access to my Vulcan compiler.

I do wonder if the MS 'men' (women included) have tried to use some sort of shared folder structure for VS 2017 install, and not logically thought through the problems and issues of de-installing and multiple version installation etc., etc.. Robert may have alluded to such a change in another post some time back.

Images attached are to aid / help those of us with imagination ;-0)
Whoops! - will have to be posted separately as I am using the copy of Edge in my VM and so the captured screen images are unavailable ;-0((

Cheers,
Phil.

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2610

  Phil Hepburn's Avatar Topic Author Phil Hepburn Offline Posts: 742
Okay guys,

Back in my main O/S and jumped out of the virtual machine.

Here are the images of success :-
Regards,

Phil.







Attachments:

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2617

  ic2's Avatar ic2 Offline Posts: 520
Hello Phil,

I do wonder if the MS 'men' (women included) have tried to use some sort of shared folder structure for VS 2017 install, and not logically thought through the problems and issues of de-installing and multiple version installation etc., etc.. Robert may have alluded to such a change in another post some time back.


I would expect something like that too. Of course I realize that many users (like Nick now) did not have any problems with VS 2017 but apart from the posting from me for which I provided the hyperlink in this thread, there were dozens of others complaints on
developercommunity.visualstudio.com/; almost daily one or more postings were added and most of the posts were followed by dozens or even 100's of others. So I think a substantial number of VS users had problems. I think it's logical that this all adds up to my opinion about VS.

Dick

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2618

  Phil Hepburn's Avatar Topic Author Phil Hepburn Offline Posts: 742
Hi Dick,

I have no issues with VS, version 2017 or earlier, it is the Installer for 2017 which is causing the issues.

Before I messed with the Installer 'remove' option in 2017 I had no issues or problems.

The previous release versions of VS have done a lot of good work for me, as well as their simpler installer, its the new "fancy" Installer which lets those MS guys down ;-0)

I have a fear that Alwyn has got himself into the Deadly Embrace as well, as I think he told me a few weeks back that he removed Community VS 2017 ;-0(( We shall have to see. Not an easy thing to deal with when your friend is 80 miles away (each way) !

It may interest you, and/or others, that I once sat through a double conference session on using VS 2005 - delivered by no lesser person that Don Caton, the man himself - father of the Vulcan compiler.

VS is a lot better than you first think it is - took me two years to 'calm down' and get into the groove. Nowadays, like Nick, I just get on and use it. I am sure there are many sides/parts to it that I don't use or even know about - but - it does a lot of good stuff for me (when it installs that is). I must have logged up many thousands of hours on it - does not however make me an expert, or anything close to one!!!

Regards,
Phil.

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2619

  robert's Avatar robert Offline Posts: 1048
Phil,

You are right. The installer seems to be the problem for VS 2017.
When you have multiple installations especially when these have different versions then it becomes really confused.
So on my test VMs I simply have different VMs with different versions of VS 2017. That works much more reliable.

I also think it is a problem that you cannot install a specific version of VS 2017. Lets say you want to have 15.2 because that is what your colleagues are using. If you happen to have the 15.2 installer and then run it, it will automatically update itself to the latest version and will insist on installing the latest version.

Robert
XSharp Development Team
The Netherlands
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

Installer - VS 2017 - issues and work arounds !? 1 year 10 months ago #2626

  ic2's Avatar ic2 Offline Posts: 520
Hello Phil,

I have no issues with VS, version 2017 or earlier, it is the Installer for 2017 which is causing the issues.


The installer was my issue too. It finished with The product failed to install the listed workloads and components due to one or more package failures.

VS 2017 then worked but not UWP apps, in my case.

You can read the solutions provided by Microsoft support in my posting:

https://developercommunity.visualstudio.com/content/problem/40056/the-product-failed-to-install-wed-like-a-serious-s.htmlhttps://developercommunity.visualstudio.com/content/problem/40056/the-product-failed-to-install-wed-like-a-serious-s.html

Dick

Please Log in or Create an account to join the conversation.

  • Page:
  • 1