fbpx
Welcome, Guest
Username: Password: Remember me
Visual Objects

Please use this forum to post questions about Visual Objects and Vulcan.NET
  • Page:
  • 1

TOPIC: Frustrating W10 problem with VO Internet calls...

Frustrating W10 problem with VO Internet calls... 9 months 1 week ago #1

  • Stavros Spanos
  • Stavros Spanos's Avatar Topic Author
  • Offline
  • Posts: 9
Hi all!

We use internet with our VO2.8 for long times without significant problems. For example we call Ftp, we connect to Google API, we get Universal Time etc.

Suddenly in some PC's (SOME Win10's) we get several errors like everything is malfunctioning concerning Internet calls (FTP returns false, http's not found etc.)

Then we reasize that...

1./ Some PC's have the problem - others don't (some of the "good" ones can be W10)

2./ When we go to a "bad" W10 PC and we run the whole executable folder from a local c:\ drive, all work as a charm...

So the problem (suddenly) has to do with running the .exe from a certain network drive while running from c:\

Is there something we miss?

TIA

Stavros

Please Log in or Create an account to join the conversation.

Frustrating W10 problem with VO Internet calls... 9 months 1 week ago #2

  • wriedmann
  • wriedmann's Avatar
  • Offline
  • Posts: 1404
  • Karma: 6
Hi Stavros,

this has nothing to do with VO, it has to do with network drives that have a SMB version older than v2.

If you have older Windows server, you need to upgrade them. If you have Linux (Samba) servers, please look here: https://www.riedmann.it/blog/?p=303 .

Microsoft has decided to cut network activities for executables that are launched from older shares. This is a security issue.

Wolfgang
Wolfgang Riedmann
Meran, South Tyrol, Italy
This email address is being protected from spambots. You need JavaScript enabled to view it.
www.riedmann.it - docs.xsharp.it

Please Log in or Create an account to join the conversation.

Frustrating W10 problem with VO Internet calls... 9 months 1 week ago #3

  • Stavros Spanos
  • Stavros Spanos's Avatar Topic Author
  • Offline
  • Posts: 9
Wolfgang thanks a lot!!!

Makes sense as the cases we are talking about have XP and 2000 to share...

We'll verify it tomorrow - you save us from a lot of trouble.

Stavros

Please Log in or Create an account to join the conversation.

Frustrating W10 problem with VO Internet calls... 9 months 1 week ago #4

I had the same problem and found a solution which worked turning on the samba 1 in Control Panel, Windows features.

Giorgio

Please Log in or Create an account to join the conversation.

Frustrating W10 problem with VO Internet calls... 9 months 1 week ago #5

Control panel, Programs and features, turn on windows features

Please Log in or Create an account to join the conversation.

Frustrating W10 problem with VO Internet calls... 9 months 1 week ago #6

  • Stavros Spanos
  • Stavros Spanos's Avatar Topic Author
  • Offline
  • Posts: 9

ngpollarolo wrote: Control panel, Programs and features, turn on windows features


You mean in the client W10 PC?

Please Log in or Create an account to join the conversation.

Frustrating W10 problem with VO Internet calls... 9 months 1 week ago #7

Yes

Please Log in or Create an account to join the conversation.

  • Page:
  • 1