fbpx

Which version of VO are you using ?

More
2 months 3 days ago #1 by robert
Which version of VO are you using ? was created by robert
We are testing the compiler and runtime with the VO SDK. Now it is time to ask 2 important questions:

1) Which version of VO are you using at this moment (eg. 2.5b3, 2.8SP3 etc) ?
2) What do you expect of the VO SDK classes in X#. Should they match your version or should they move everybody to the same VO SDK ?

I am looking forward to your answers.

Robert

XSharp Development Team
The Netherlands
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #2 by wriedmann
Replied by wriedmann on topic Which version of VO are you using ?
Hi Robert,

I'm using 2.8 SP4 (the latest version ever released), and I would expect an X# library of exactly this version, because it contains all the latest fixes.

One the one side it would be a nightmare to support all the older versions and builds of the class libraries, but for a user of VO 2.5/2.6 or 2.7 the use of a newer version could be a supplemental work, and it would make it impossible to keep the sources syncronized between VO and X#.

Wolfgang

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #3 by wriedmann
Replied by wriedmann on topic Which version of VO are you using ?
Hi Robert,

I have another possible issue: I'm not sure that the SDK code we have is really the most recent source of the class library binaries.

Wolfgang

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #4 by FFF
Replied by FFF on topic Which version of VO are you using ?
1) The little i did at last in VO is 2.8Sp4.
2) I'd unify to reduce the burden for support ;)

Karl

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #5 by robert
Replied by robert on topic Which version of VO are you using ?
Wolfgang,

I happen to know the guy that created these class library binaries ;)

Robert

XSharp Development Team
The Netherlands
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #6 by wriedmann
Replied by wriedmann on topic Which version of VO are you using ?
Fortunately!

Wolfgang

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #7 by g.bunzel@domonet.de
Replied by g.bunzel@domonet.de on topic Which version of VO are you using ?
Hi Robert,

...my VO starting windows shows Version 2.8 SP4b, build 2838

To support the latest version should be enough.
If there are differences to older versions, then there is a little work - like from VO25 to Vo26 to Vo27 to VO28.
Then we have one version of the VO SDK classes in X# for the future.

Best regards

Gerhard

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #8 by lumberjack
Replied by lumberjack on topic Which version of VO are you using ?
Hi Robert,

robert wrote:
1) Which version of VO are you using at this moment (eg. 2.5b3, 2.8SP3 etc) ?

VO 2.6

2) What do you expect of the VO SDK classes in X#. Should they match your version or should they move everybody to the same VO SDK ?

I would go for the same VO SDK for everybody.
Regards,

______________________
Johan Nel
George, South Africa

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #9 by kitz
Replied by kitz on topic Which version of VO are you using ?
Hi!

I use mostly 2740, but also 2822, 2837 and 2838.
But I am happy with compatibility to the last VO version.

I was not able to move from 2740 because of SQL-Classes. There were some changes at setting connection parameters, where my backend refused to connect and produced error messages.
Would have to use SDK to do changes and get workarounds running.
Now trying to move to X# directly to leave all VO behind.
BR Kurt

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #10 by Karl-Heinz
Replied by Karl-Heinz on topic Which version of VO are you using ?
I have VO 2.8 SP4, but i´m using SP3 only - and i don´t want to change that.

regards
Karl-Heinz

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #11 by AlessandroV
Replied by AlessandroV on topic Which version of VO are you using ?
Hi Robert,

i am using VO 2.8 SP4(2838), last version.
I have migrate all my VO software from VO2.7 to 2.8 without great problems.

Thanks for your great job.

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #12 by ovo
Replied by ovo on topic Which version of VO are you using ?
Hi Robert,
I'm using VO 2.8 SP4 for my main apps. For me it is sufficient if that version is supported.

Stefan

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #13 by gianluca.pinoli
Replied by gianluca.pinoli on topic Which version of VO are you using ?
Hi Robert,
1) i mainly use VO2.8 SP4 ( but i still have a couple of project in VO2.6 ) with a massive use of bBrowser

2) X# library could match VO2.8 SP4 only. I'd really like to have bBrowser's version compatible with X# Runtime.

Regards
Gianluca

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #14 by robert
Replied by robert on topic Which version of VO are you using ?
Gianluca,

bBrowser is another story. We don't own that and cannot deliver it. I'll approach Joachim Bieler about this once we have the SDK compiling and running.

We WILL deliver updated versions of RP2 and RP3, and my own company will deliver an updated version of Vn2Ado (renamed to XS2Ado)

Robert

XSharp Development Team
The Netherlands
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #15 by gianluca.pinoli
Replied by gianluca.pinoli on topic Which version of VO are you using ?
Thanks Robert,
I look forward to know Joachim's feedback.

Regards
Gianluca

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #16 by wriedmann
Replied by wriedmann on topic Which version of VO are you using ?
Hi Gianluca,

I have been in contact with Joachim a few days ago, and he has confirmed that the will deliver an X# version of bBrowser.

Wolfgang

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #17 by gianluca.pinoli
Replied by gianluca.pinoli on topic Which version of VO are you using ?
Thanks Wolfgang

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #18 by leon_ts
Replied by leon_ts on topic Which version of VO are you using ?
Hi,

1) VO 2.8 SP3 (2837)
2) Requires support for the specified version. Upgrade to SP4 is not planned.

Best regards,
Leonid

Please Log in or Create an account to join the conversation.

More
2 months 2 days ago #19 by Jamal
Replied by Jamal on topic Which version of VO are you using ?
1. VO 2.8 SP4b(2838).
2. Stick with one version of the VO SDK, otherwise it will be a maintenance nightmare.

Jamal

Please Log in or Create an account to join the conversation.

More
2 months 2 days ago #20 by lorenzi@moduline.ch
Replied by lorenzi@moduline.ch on topic Which version of VO are you using ?
Hi Robert

I use VO 2773 (the last Version before 2.8).


Markus

Please Log in or Create an account to join the conversation.