fbpx

Intellisense: Peek/goto definition stopped working

More
5 months 2 weeks ago #1 by Dick
I have the following code:

EXPORT oDBTranslate AS ic2DbServer

When I right click on it and either chose Peek or Goto definition, nothing happens in VS. I rechecked the VS Intellisense settings but as far as I can see everything is still set as it was, a mircacle on it's own.

In VO, I can choose to go to the class, init, preinit and postinit.

On further investigation it seems the whole Peek/Goto stopped working altogether. I tried typing an existing function and ended up with the error below as soon as I typed a parenthesis. I also opened the XML log (81 kb!) ; it's uploaded too but renamed to .txt as XML is not allowed.

I also still have VS 2015 installed and there it goes wrong exactly the same way. So I suspect it may be a X# issue with the latest release? Does this make any sense to any of you?

Dick
Attachments:

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago - 5 months 2 weeks ago #2 by Dick
I just found in the subscriber forum that it's a known bug. Hope it gets solved soon. Intellisense keeps being a bit of a trouble area but that doesn't surprise me with Visual Studio. I'm always surprised that something which worked yesterday still works today.

Oh, one thing more. articles just posted are called "COM_KUNENA_MESSAGE_CREATED_NEW " again. Robert fixed this a while ago.

Dick
Last edit: 5 months 2 weeks ago by Dick.

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #3 by Fabrice Foray
Replied by Fabrice Foray on topic Intellisense: Peek/goto definition stopped working
Hi Dick,
the error message you've posted indicate a file and it's location (c:\Users....\ActivityLog.xml)
Can you please get this file and send it to my email address This email address is being protected from spambots. You need JavaScript enabled to view it. ?
Thanks

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #4 by Dick

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #5 by Fabrice Foray
Replied by Fabrice Foray on topic Intellisense: Peek/goto definition stopped working
Ok, thanks ! Got it, I will see what I can do.

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #6 by Dick
Thank you!

In the meantime I de-installed Bandol 3 and reinstalled version 120 of last April. This works fine with our projects as it seems now so you do not need to hurry.

I can quickly reinstall Bandol 3 should any of you be helped with looking what happens (with Teamviewer for example)

Dick

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #7 by Dick
Hello Fabrice,

Yesterday I installed X# 120. Today (after de-installing VS 2015 and adding VS 2017 Community, next to Professional) I had to reinstall X#; otherwise VS does not recognize X#. So I took Bandol 3 again, and now it seems to work again!
So in case you don't find an obvious: cause de-installing and reinstalling seems to cure it. Which is not unusual when using VS: most programmers spend more time repairing and reinstalling VS or components than in programming :(

Please Log in or Create an account to join the conversation.