fbpx

XSharp Bandol Beta 3 New Popular: error MC1000

More
6 months 11 hours ago - 6 months 11 hours ago #1 by Jelle
Hello all, I just installed XSharp Bandol Beta 3 after using XSharp 1.2.1 in Visual Studio 2017 and sadly I cannot start my project anymore after the new installation. I don't get an error in the Error List, however when building in the Output screen I do get this:
3>------ Build started: Project: (My Project name), Configuration: Debug Any CPU ------
3>C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.WinFx.targets(268,9): error MC1000: Unknown build error, 'Cannot resolve dependency to assembly 'VulcanRT, Version=4.0.401.0, Culture=neutral, PublicKeyToken=0e73a8bf006af00c' because it has not been preloaded. When using the ReflectionOnly APIs, dependent assemblies must be pre-loaded or loaded on demand through the ReflectionOnlyAssemblyResolve event.' 
3>Done building project "(My Project name).xsproj" -- FAILED.

What could be the cause of this?
Last edit: 6 months 11 hours ago by Jelle.

Please Log in or Create an account to join the conversation.

More
6 months 11 hours ago #2 by Chris Pyrgas
Replied by Chris Pyrgas on topic XSharp Bandol Beta 3 New Popular: error MC1000
Hi Dick,

Is this with the VS solution that you have sent to me some time ago? Because I have tested it and it builds fine here. Please try removing the references to the vulcan dlls and add them again, does it work now? If not, can you please send me the current version of the solution to have a look?

Chris

XSharp Development Team
chris(at)xsharp.eu

Please Log in or Create an account to join the conversation.

More
5 months 4 weeks ago #3 by Dick
Hello Chris,

Not sure - Jelle got & posted this error. My recent copies from him seem to compile so if he re-applies the Vulcan dll's Monday it may work again -- if not he'll let you know with more info.

Dick

Please Log in or Create an account to join the conversation.

More
5 months 4 weeks ago #4 by Chris Pyrgas
Replied by Chris Pyrgas on topic XSharp Bandol Beta 3 New Popular: error MC1000
Hi Dick,

OK, in case there does still exist a problem, please zip the solution and send it to me to have a look.

Chris

XSharp Development Team
chris(at)xsharp.eu

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago #5 by Jelle
Hello,

Yes the problem is solved now, here is what i had to do:

I had 1 solution but this had multiple projects. One of the projects that did have the DLL, builded fine on its own. However another project didn't have this reference to the DLL's. However, it worked before the update, and I forgot if it did or didn't have these references. Either it did and this update removed these references (which I found hard to believe but not impossible). Or this project didn't have these DLL's to begin with, since It was a small testing project so this might be the case... I forgot...

Or i somehow deleted the reference in between, which i also found hard to believe because the solution worked fine, then I updated and then immediately tested it again.

However, thanks for the help!

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago #6 by Chris Pyrgas
Replied by Chris Pyrgas on topic XSharp Bandol Beta 3 New Popular: error MC1000
OK, in any case glad it is working fine now!

XSharp Development Team
chris(at)xsharp.eu

Please Log in or Create an account to join the conversation.