fbpx

Question about “Create COM Interop Assemblies”

More
1 year 1 month ago #1 by Johan Kwaspen
Dear,

I have a “VO-import program” that need the IXMLDOMDocument{}.

When I start the tool: “Create assemblies form” Choose: “Microsoft XML, v6.0” , Import type: TLBimp.exe, the XIDE 1.11 freeze.
The Importer “Aximp.exe” works and I see the result in the “COM-tab-page”, but the Add-button doesn’t response. (it is not possible to include it)

Is there a way to include this ?


Thanks a lot for the response,

Johan Kwaspen

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #2 by Chris Pyrgas
Replied by Chris Pyrgas on topic Question about “Create COM Interop Assemblies”
Hi Johan,

I am also seeing that problem, what happens is that XIDE calls tlbimp.exe and waits for it to exit, but for some reason it never exits with the Microsoft XML libraries, hence the freeze. For the next version I will add a timeout of a few seconds so the IDE does not freeze, but I don't know why tlbimp does not work with those libraries and a goggle search didn't show something either.

Can you please try creating them from VS instead, to see if that works? Just create a new x# or c# project in it (any type) and add a reference to this library. VS should create the dlls for the library (also by using tlbimp) and will add them as references to the project. Now you can just copy those dlls anywhere you like in your disk and add direct references to them also in your XIDE apps.

Chris

XSharp Development Team
chris(at)xsharp.eu

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #3 by Karl Faller
Replied by Karl Faller on topic Question about “Create COM Interop Assemblies”
Chris,
seemt to remember, i had the same problem sometime ago, "no go" from Xide, "no problem" from VS...

Karl

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #4 by Chris Pyrgas
Replied by Chris Pyrgas on topic Question about “Create COM Interop Assemblies”
Hi Karl,

Yeah, it's a microsoft tool and a microsoft (XML) library, so it makes sense that they know better how to use the tool to work properly with their library :)
Unfortunately I couldn't find an indication on what the actual problem might be, so I can fix that in XIDE as well..

Chris

XSharp Development Team
chris(at)xsharp.eu

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #5 by Johan Kwaspen
Replied by Johan Kwaspen on topic Question about “Create COM Interop Assemblies”
Hello Chris, Karl

Thanks for your reply,
I could continue, I write the method in order to X# code.
So I get the X # in the fingers.

Regard,

Johan Kwaspen
Belgium

Please Log in or Create an account to join the conversation.