fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Public 2.5b 01 Sep 2020 20:52 #15793

  • hsc's Avatar

  • hsc

  • Topic Author


  • Posts: 130
  • Hi All


    today I wanted to test the public version 2.5b xSharp. I installed it in the VS2019 community. After trying to create a new WPF application I got this error (attachment). The same is true in VS 2017.

    Juraj
    Attachments:

    Please Log in or Create an account to join the conversation.

    Public 2.5b 01 Sep 2020 22:08 #15794

  • Chris's Avatar

  • Chris


  • Posts: 2126
  • Hi Juraj,

    Just to make sure if it is a X# or general problem, please try creating a c# WPF project, does this one work ok?
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    Public 2.5b 02 Sep 2020 08:01 #15796

  • hsc's Avatar

  • hsc

  • Topic Author


  • Posts: 130
  • Hi Chris,

    in c# work xaml designer OK. After reinstall old version X# (2RC1Fox) work xaml designer ok.

    Juraj

    Please Log in or Create an account to join the conversation.

    Public 2.5b 02 Sep 2020 09:18 #15797

  • robert's Avatar

  • robert


  • Posts: 1862
  • Juraj,
    What happens if you right click on the filename, choose "Open With" and then "XAML Designer".
    Can you open the window that way ?

    Robert
    XSharp Development Team
    The Netherlands

    Please Log in or Create an account to join the conversation.

    Public 2.5b 02 Sep 2020 09:39 #15798

  • Chris's Avatar

  • Chris


  • Posts: 2126
  • Robert,

    I can confirm the problem, in both VS2017 and VS2019, with the 2.5 public build. And indeed, with Open With, the WPF form does open correctly!
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    Public 2.5b 02 Sep 2020 23:38 #15799

  • ic2's Avatar

  • ic2


  • Posts: 755
  • Hello Juraj, Robert, Chris,

    I posted this August 10 and a while later I also solved it with Open with

    www.xsharp.info/forum/public-product/209...lable-for-xaml#15519

    I think it's a VS issue. I remember I've seen it before, I think with C#. Almost everything which can go wrong with VS will go wrong at some point in time.

    Dick

    Please Log in or Create an account to join the conversation.

    Last edit: by ic2.

    Public 2.5b 03 Sep 2020 16:00 #15803

  • robert's Avatar

  • robert


  • Posts: 1862
  • Dick,

    this is NOT a VS issue but something in our code.

    Robert
    XSharp Development Team
    The Netherlands

    Please Log in or Create an account to join the conversation.

    Public 2.5b 03 Sep 2020 16:46 #15805

  • ic2's Avatar

  • ic2


  • Posts: 755
  • Hello Robert,

    robert wrote: Dick,
    this is NOT a VS issue but something in our code.


    Could be but I am sure I've had this issue before and I usually ask or report it in this forum (or in the NG X#, before Vulcan). I could only find a Vulcan bug (logged it as bug #1070) where the VS editor crashed when on trying to edit WPF (2011) and no postings from me concerning that message.

    So I am almost certain I saw it in C#. If you search on this message there a pages full about this error.

    If you can prevent it in X#: that's great of course. But it may be not entirely an X# issue I'd say.

    Dick

    Please Log in or Create an account to join the conversation.

    • Page:
    • 1