fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: XSharp app in Windows Vista

XSharp app in Windows Vista 07 Nov 2019 18:50 #11644

  • hsc's Avatar

  • hsc

  • Topic Author


  • Posts: 126
  • Hi All

    I want to run xSharp app in Vulcan dialect on computer with Windows Vista 32. I get a .Net error after starting. Any experience?

    Juraj

    Please Log in or Create an account to join the conversation.

    XSharp app in Windows Vista 07 Nov 2019 18:59 #11645

  • wriedmann's Avatar

  • wriedmann


  • Posts: 2232
  • Hi Juraj,
    AFAIK the needed .NET version (4.7) is not available in Windows Vista.
    X# applications without runtime (Core dialect) can be run even on Windows XP.
    Wolfgang
    Wolfgang Riedmann
    Meran, South Tyrol, Italy

    www.riedmann.it - docs.xsharp.it

    Please Log in or Create an account to join the conversation.

    XSharp app in Windows Vista 07 Nov 2019 19:07 #11646

  • hsc's Avatar

  • hsc

  • Topic Author


  • Posts: 126
  • HI Wolfgang

    Thank you for your response. App was imported from Vulcan into VS2017 and framework is set to 4.0, because I need Oledb for MDB database.

    Please Log in or Create an account to join the conversation.

    XSharp app in Windows Vista 07 Nov 2019 19:17 #11647

  • wriedmann's Avatar

  • wriedmann


  • Posts: 2232
  • Hi Juraj,
    since you are using the X# runtime for the Vulcan dialect you need at least .NET Framework 4.7 on this machine, and AFAIK this version is not available on Windows Vista (out of maintainance by Microsoft for a few years now).
    Even Windows 7 will exit from support next January...
    Wolfgang
    P.S. maybe the application will work using the Vulcan runtime with the X# compiler
    Wolfgang Riedmann
    Meran, South Tyrol, Italy

    www.riedmann.it - docs.xsharp.it

    Please Log in or Create an account to join the conversation.

    XSharp app in Windows Vista 07 Nov 2019 20:21 #11648

  • hsc's Avatar

  • hsc

  • Topic Author


  • Posts: 126
  • Hi Wolfgang

    if I using Vulcan runtime app not work.
    I rewrote the main part into Core dialect and program works . You had to convert, XSharp in Core dialect also works in Vista. Super, thanks for advice.

    Juraj

    Please Log in or Create an account to join the conversation.

    • Page:
    • 1