fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: xsharp plugin doesn´t work

xsharp plugin doesn´t work 1 year 1 month ago #4620

  Karl-Heinz's Avatar Topic Author Karl-Heinz Offline Posts: 264
1. i copied the ILSpy.XSharpLanguage.Plugin.dll to my ilspy dir

2. After selecting "Xsharp" from the combobox i get the error that the method "ICSharpCode.Decompiler.DecompilerSettings.get_ExpandMemberDefinitions()" is not found.
See attached jpg. When i load the ICSharpCode.Decompiler.dll and search for "get_ExpandMemberDefinitions" or something like "ExpandMember" nothing is found.

- i´m running x64 Win8.1
- ilspy Version is 3.0.1.3459
- ILSpy.XSharpLanguage.Plugin.dll version is 1.0.65534.65534

any ideas what´s wrong ?

regards
Karl-Heinz
Attachments:

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4621

  Karl-Heinz's Avatar Topic Author Karl-Heinz Offline Posts: 264
what does the forum-software do with my jpg ????

Here´s a link to get a readable image.

www.rauscher-software.de/downloads/XsharpPluginErr.jpg

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4622

  FFF's Avatar FFF Offline Posts: 574
Karl-Heinz,
same os here,
my exe shows ILSpy version 3.1.0.3652,
the dll is "yours.
- For me, it runs ;)

BTW, @Chris,Fabrice, looking into some code i see things like:
public virtual property Response as HttpResponse 
		getend get
		private setend set

no idea what "getend" should be - is this "right"?

Thx
Karl

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4623

  Chris's Avatar Chris Offline Posts: 1163
Guys,

You need to use the version of ILSpy that Fabrice mentioned, from github.com/icsharpcode/ILSpy/releases

Karl, it looks like some CRLFs are missing from the code. There should be a new line between "get" and "end" in "getend" :)

Chris
XSharp Development Team
chris(at)xsharp.eu

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4624

  Karl-Heinz's Avatar Topic Author Karl-Heinz Offline Posts: 264
Hi Chris,

I´m using IlSpy since several years - current version (was): 3.0.1.3459. i thought that when i select "Check for Updates" i *always* get a notify when a newer version is available. Because i got the hint "You are using the latest version" i thought it´s enough to simply add the ILSpy.XSharpLanguage.Plugin.dll from the X# download site.

Anyway, after extracting the files from the mentioned zip i´m now on version 3.1.0.3652 and "XSharp" works.

regards
Karl-Heinz

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4625

  Karl-Heinz's Avatar Topic Author Karl-Heinz Offline Posts: 264
Hi Karl,

>
> same os here,
>

i love 8.1 :-)Never any crashes or update problems, so I´ll stay with it til 10.01.2023 ;-).

regards
Karl-Heinz

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4627

  Chris's Avatar Chris Offline Posts: 1163
Hi Karl-Heinz,

Karl-Heinz Rauscher wrote: I´m using IlSpy since several years - current version (was): 3.0.1.3459. i thought that when i select "Check for Updates" i *always* get a notify when a newer version is available. Because i got the hint "You are using the latest version" i thought it´s enough to simply add the ILSpy.XSharpLanguage.Plugin.dll from the X# download site.


Yes, I was caught by the exact same thing and was very puzzled. Guess it's a problem of the updating mechanism of ILSpy, although I am not absolutely certain, did not look more into it, just downloaded the new files and it worked. A small issue I guess, but ILSpy is too good (and free!) to complain about that :)

Btw, Win 7 works even better for me, especially when combined with Classic Shell, which undoes many of the design insaneties they are introducing in the last years...:)

Chris
XSharp Development Team
chris(at)xsharp.eu

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4629

  Phil Hepburn's Avatar Phil Hepburn Offline Posts: 742
Hi Chris,

I can confirm that there are times that a SPACE character is missed out in the X# code generated by the plug-in.

I have attached an image of the ILSpy code - look at the three lines either last, or second to last in the three Async methods - the 'await' keyword has a space missing that should follow it directly.

Luckily we can tell where the blue colour finishes and the black colour starts - this is where the space should be.

I may have another issue to report, BUT, the ILSpy plugin did get me a working program after a tweak or two ;-0)

Regards,
Phil.

Attachments:

Please Log in or Create an account to join the conversation.

xsharp plugin doesn´t work 1 year 1 month ago #4631

  Fabrice's Avatar Fabrice Offline Posts: 51
Hi Karl,
thanks for the feedback : I will try put this one in my todo list..but with VSIntegration and DBF RDD, priorities are getting hard to define ! :)

Fab

Please Log in or Create an account to join the conversation.

  • Page:
  • 1