fbpx
Welcome, Guest
Username: Password: Remember me
Qui si parla italiano
  • Page:
  • 1

TOPIC: Formattazione di una data

Formattazione di una data 02 Oct 2019 10:33 #11018

  • gianluca.pinoli's Avatar

  • gianluca.pinoli

  • Topic Author


  • Posts: 29
  • Ciao a tutti,
    ieri ricompilando un progetto dopo l'installazione della versione 2.07 (ma non sono sicuro sia questa la causa del problema) ho cominciato ad avere un errore che riguarda la seguente riga:

    sQuery := i"UPDATE infoart SET vecchiocos=oldcos_1,cambiocost='{dData:yyyy-MM-dd}'"

    ErroreXS1061'System.DateTime' does not contain a definition for 'yyyy' and no accessible extension method 'yyyy' accepting a first argument of type 'System.DateTime' could be found (are you missing a using directive or an assembly reference?)MeatShopC:\Users\Gianluca\Documents\Visual Studio 2019\Projects\MeatShop\MeatShop\GestioneReseForm.prg977
    "ErroreXS1061'System.DateTime'" non รจ riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.

    Ho risolto il problema modificando la formattazione della stringa in questo modo:
    sQuery := String.Format("UPDATE infoart SET vecchiocos=oldcos_1,cambiocost='{0}'",dData:ToString("yyyy-MM-dd"))

    Qualcuno sa come fare funzionale la precedente sintassi?

    Graze
    Gianluca

    Please Log in or Create an account to join the conversation.

    Formattazione di una data 02 Oct 2019 10:55 #11019

  • wriedmann's Avatar

  • wriedmann


  • Posts: 2232
  • Ciao Gianluca,
    teoricamente dovrebbe funzionare anche quella sintassi che ha funzionato in precedenza - possibilmentesi tratta di un errore della 2.07.
    Vediamo cosa dice Chris...
    Saluti
    Wolfgang
    Wolfgang Riedmann
    Meran, South Tyrol, Italy

    www.riedmann.it - docs.xsharp.it

    Please Log in or Create an account to join the conversation.

    Formattazione di una data 02 Oct 2019 16:52 #11025

  • Chris's Avatar

  • Chris


  • Posts: 1892
  • Hi guys,

    Yes, this looks like a bug, that should be supported as well. But it is not a new bug in 2.07, I checked and at least in 2.06 it was the same, not sure if it was working earlier than that. In any case, this will be fixed, thanks for the report!
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    • Page:
    • 1
    Moderators: wriedmann